ICDSOFT

News

Subscribe

PHP 5.6 and PHP 7.0 available on all servers

Completing a schedule of gradual upgrades, as of today all our servers run PHP 5.6 as default PHP interpreter.

Also, following our policy to provide the latest stable technologies, PHP 7.0 is installed and available on all machines. Customers can switch their domains, or just some folders, to use PHP 7.0 as default interpreter.

PHP 5.3 is still running on our servers to allow customers with older software time to ensure compatibility with newer PHP versions. PHP 5.3 will be available for a limited period of time, as it is in end-of-life status.


Reseller Overdraft feature

Given our close-to-zero marketing budget, the Reseller program could be considered our main marketing tool. That's why we are constantly looking into improving the experience of our resellers and optimizing their operations. Following this goal, today we extended the Overdraft feature specifications, so that it is now enabled for a greater number of our resellers.

The Overdraft in the Reseller Panel allows resellers to purchase and renew services without submitting a payment through a payment processor immediately. Instead, they are able to pay using the allowed overdraft until the overdraft limit is reached. Once a month, the reseller can cover all purchased services with a single transaction. The Overdraft is not a financial feature - there are absolutely no interest rates, taxes, or fees involved. The mere purpose of the Overdraft feature is to allow resellers to purchase services faster, without requiring an immediate payment transaction for each order.

So far, the Overdraft feature was used by a small number of our larger resellers. As of today, the allowed overdraft is calculated for each reseller individually, according to a dynamic formula based on the number and type of their active hosting accounts. Generally, the more accounts a reseller has in their panel, the greater the allowed overdraft would be. All resellers who are entitled to an overdraft of more than $100 USD, now have the Overdraft feature visible in their Account Balance section, and they can use the overdraft as a payment method.

The extension of the overdraft availability amongst more resellers also allows us to lower our transaction costs, due to the smaller number of transactions involved. Every business is usually interested in lowering costs and optimizing performance, and we are no exception to that. Of course, there are certain areas in which we would not look into cutting costs, such as our server hardware, network connectivity, or personnel costs - these are the areas that have direct influence on the level of our service. However, when it comes to transaction costs, any available resources spared would simply be directed to other more vital areas, as the ones mentioned.

The Overdraft could be very useful along with the Online Stores feature in the Reseller Panel. As a reseller, you can set up an online store on your website linked to your reseller account with us. Then, when a customer submits an order and a payment to you on your website, the order would be received in your Reseller Panel, and automatically processed by us using your overdraft as a payment method. Thus, your customer would receive their service immediately, at any time of the day or the week. You just need to check your reseller balance regularly, and cover the outstanding amounts when needed. You can check the Reseller Panel documentation, as well as contact us, for more information on how to set up your reseller website. This setup could work for any reseller, even without an enabled overdraft, by simply topping up the account balance when necessary.

We hope that the overdraft availability will help our resellers with the expansion of their business.


MySQL 5.6.27 installed on all servers

As of this week, MySQL 5.6.27 has been installed on all our servers.

When considering server software updates, we always try to balance between providing the newest technologies, ensuring the security of the services we offer, and providing enough time to customers to deal with software related matters, in case their site software is not compatible. The security of our servers is a top priority - in case a critical software vulnerability is found that may affect the security of the whole server, we will be making these software updates immediately.

Due to security fixes in MySQL 5.6.27 and the lack of known backward compatibility problems, our system administrators have installed it on all our servers, forcing its usage by all customers. All previous/older MySQL versions are no longer available.


Another tool for our resellers - Online Stores for hosting services

We have always paid special attention to our reseller program, as it is an essential part of our business model. The success of our resellers will be our own success as well, and we are well aware how important it is our resellers to have the proper tools for their operations.

Our software team released today a new tool in our Reseller Panel - the Online Stores. Its main purpose is to allow resellers to automate the ordering process, and thus assist them in growing a successful reseller business.

With the Online Stores tool, our resellers can create online stores for hosting services, set prices and settings for each store, and utilize a site widget, which would display the order form on the reseller website(s). Customers of the reseller are able to purchase services on the reseller website(s), submit a payment to the reseller, and have the service enabled on our side immediately. Thus, the whole ordering process can be fully automatic, with orders processed 24/7, without any intervention by the reseller.

We will continue to expand the Online Stores tool, by adding more products, features, and payment options.


PHP 5.5 available on all servers

Following our policy to provide the most recent server technologies which we consider stable enough for production environment, PHP 5.5 is now available on all our servers. Customers can now choose between PHP 5.5 and PHP 5.3 as default PHP interpreter for their accounts.

We are well aware that PHP 5.3 is no longer supported by PHP developers. However, according to our analysis PHP 5.3 still does not pose a security threat to hosting servers. That's why we decided that we will keep it for now, giving our customers enough time to make their software compatible with PHP 5.5 - PHP versions over 5.3 introduce major changes that require some older sites/software to be rewritten.

Security of course is a primary concern, and our system administrators are closely monitoring the situation around PHP 5.3. If a security vulnerability is ever discovered, PHP 5.3 will be removed immediately. That's why we advise customers to make sure that their PHP sites/software are compatible with PHP versions over 5.3.